E1.1 What devices does Blrt support?

Blrt for iOS requires iOS 7.0 or above and works on the following iPads, iPhones and iPods:

  • iPad 2
  • iPad (3rd generation)
  • iPad (4th generation)
  • iPad Air
  • iPad Mini
  • iPad Mini Retina
  • iPhone 4*
  • iPhone 4S
  • iPhone 5
  • iPhone 5S
  • iPhone 5C
  • iPhone 6
  • iPhone 6+
  • iPod Touch (5th generation)


Blrt for Android OS requires a minimum version 4.0.3.

Feedback and Knowledge Base